java-decompiler (JD)在官方下载后,在mac osx下无法使用,说无法找说合适的jdk,(我电脑上jdk是jdk8),那可以用以下两种方式使用

  1. 打开应用的包,找到jd-gui-x.y.z-min.jar包(min是指压缩后的包),把它复制到好找的位置,然后执行命令:java -jar jd-gui-x.y.z.jar
  2. 使用源码,编译后,找到编译后的jar包,然后执行命令:java -jar jd-gui-x.y.z.jar
    1. 源码地址:https://github.com/java-decompiler/jd-gui
    2. 通过git clone命令下载项目;
    3. 在项目目录下执行./gradle build即可,注意尽量不要用系统自己的gradle,因为系统中的版本一般会太高;

发表评论