转自:https://www.cnblogs.com/qyf404/p/5473463.html

起因

最近到一个项目组,用了一套高大上的运维工具来搭建开发环境.
有vagrant控制VirtualBox启动虚拟机.有ansible来运行playbook初始化环境.

然后遇到了一个坑,项目现有的playbook可以在ansible 1.9.6里面正常运行,而在ansible 2.0.2里执行失败了.而我在机器直接运行 pip install ansible 给我安装了最新版本,成功的跌到这个坑里了.

解决方式

解决起来也很简单.只要执行命令pip时指定具体版本就好.

  • 先用命令pip freeze查看已经安装的package及版本.
  • 如果安装了ansible,就执行命令pip uninstall ansible卸载之.
  • 最后运行命令pip install ansible==1.9.6安装我们要的版本.

发表评论